Skip to content
CVE PROGRAM SOURCE RECORD6.3 Medium

CVE-2026-59898

Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation

Description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

netty netty

  • >=4.2.0.Final, < 4.2.16.Finalaffected
  • < 4.1.136.Finalaffected

References