{"id":"CVE-2026-59898","state":"PUBLISHED","title":"Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation","description":"Netty is an asynchronous, event-driven network application framework.  Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.","publishedAt":"2026-07-29T18:02:07.415Z","updatedAt":"2026-07-30T15:19:36.357Z","severity":{"score":6.3,"label":"Medium","version":"4.0","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["netty netty"],"affected":[{"vendor":"netty","product":"netty","versions":[{"version":">=4.2.0.Final, < 4.2.16.Final","status":"affected"},{"version":"< 4.1.136.Final","status":"affected"}]}],"references":["https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg","https://github.com/netty/netty/releases/tag/netty-4.1.136.Final","https://github.com/netty/netty/releases/tag/netty-4.2.16.Final"],"weaknesses":["CWE-444"],"ingestedAt":"2026-10-29T20:12:32.778Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2026/59xxx/CVE-2026-59898.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2026-59898","state":"PUBLISHED","datePublished":"2026-07-29T18:02:07.415Z","dateUpdated":"2026-07-30T15:19:36.357Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2026-07-07T16:40:07.984Z"},"containers":{"cna":{"title":"Netty: WebSockets V07/V08 handshaker missing Connection/Upgrade validation","descriptions":[{"lang":"en","value":"Netty is an asynchronous, event-driven network application framework.  Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final."}],"affected":[{"vendor":"netty","product":"netty","versions":[{"version":">=4.2.0.Final, < 4.2.16.Final","status":"affected"},{"version":"< 4.1.136.Final","status":"affected"}]}],"references":[{"url":"https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg","name":"https://github.com/netty/netty/security/advisories/GHSA-4mp9-239f-g9hg","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/netty/netty/releases/tag/netty-4.1.136.Final","name":"https://github.com/netty/netty/releases/tag/netty-4.1.136.Final","tags":["x_refsource_MISC"]},{"url":"https://github.com/netty/netty/releases/tag/netty-4.2.16.Final","name":"https://github.com/netty/netty/releases/tag/netty-4.2.16.Final","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV4_0":{"attackVector":"NETWORK","attackComplexity":"HIGH","attackRequirements":"NONE","privilegesRequired":"NONE","userInteraction":"NONE","vulnConfidentialityImpact":"NONE","vulnIntegrityImpact":"NONE","vulnAvailabilityImpact":"NONE","subConfidentialityImpact":"LOW","subIntegrityImpact":"LOW","subAvailabilityImpact":"NONE","baseScore":6.3,"baseSeverity":"MEDIUM","vectorString":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-444","lang":"en","description":"CWE-444: Inconsistent Interpretation of HTTP Requests ('HTTP Request/Response Smuggling')","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2026-07-29T18:02:07.415Z"},"source":{"advisory":"GHSA-4mp9-239f-g9hg","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2026-07-30T13:55:09.323754Z","id":"CVE-2026-59898","options":[{"Exploitation":"none"},{"Automatable":"no"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2026-07-30T15:19:36.357Z"}}]}}}