Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2025-58066

DoS Vulnerability in ntpd-rs

Description

nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

pendulum-project ntpd-rs

  • >= 1.2.0, < 1.6.2affected

References