{"id":"CVE-2025-58066","state":"PUBLISHED","title":"DoS Vulnerability in ntpd-rs","description":"nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible.","publishedAt":"2025-08-29T20:54:13.174Z","updatedAt":"2025-09-02T13:53:59.838Z","severity":{"score":5.3,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","source":"GitHub_M"},"assigner":"GitHub_M","products":["pendulum-project ntpd-rs"],"affected":[{"vendor":"pendulum-project","product":"ntpd-rs","versions":[{"version":">= 1.2.0, < 1.6.2","status":"affected"}]}],"references":["https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-4855-q42w-5vr4","https://github.com/pendulum-project/ntpd-rs/commit/da37cf167736cbd4d7804b1ed7ceb572468298e0"],"weaknesses":["CWE-406"],"ingestedAt":"2026-10-29T20:09:39.787Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/58xxx/CVE-2025-58066.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2025-58066","state":"PUBLISHED","datePublished":"2025-08-29T20:54:13.174Z","dateUpdated":"2025-09-02T13:53:59.838Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2025-08-22T14:30:32.222Z"},"containers":{"cna":{"title":"DoS Vulnerability in ntpd-rs","descriptions":[{"lang":"en","value":"nptd-rs is a tool for synchronizing your computer's clock, implementing the NTP and NTS protocols. In versions between 1.2.0 and 1.6.1 inclusive servers which allow non-NTS traffic are affected by a denial of service vulnerability, where an attacker can induce a message storm between two NTP servers running ntpd-rs. Client-only configurations are not affected. Affected users are recommended to upgrade to version 1.6.2 as soon as possible."}],"affected":[{"vendor":"pendulum-project","product":"ntpd-rs","versions":[{"version":">= 1.2.0, < 1.6.2","status":"affected"}]}],"references":[{"url":"https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-4855-q42w-5vr4","name":"https://github.com/pendulum-project/ntpd-rs/security/advisories/GHSA-4855-q42w-5vr4","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/pendulum-project/ntpd-rs/commit/da37cf167736cbd4d7804b1ed7ceb572468298e0","name":"https://github.com/pendulum-project/ntpd-rs/commit/da37cf167736cbd4d7804b1ed7ceb572468298e0","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"LOW","attackVector":"NETWORK","availabilityImpact":"LOW","baseScore":5.3,"baseSeverity":"MEDIUM","confidentialityImpact":"NONE","integrityImpact":"NONE","privilegesRequired":"NONE","scope":"UNCHANGED","userInteraction":"NONE","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-406","lang":"en","description":"CWE-406: Insufficient Control of Network Message Volume (Network Amplification)","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateUpdated":"2025-08-29T20:54:13.174Z"},"source":{"advisory":"GHSA-4855-q42w-5vr4","discovery":"UNKNOWN"}},"adp":[{"title":"CISA ADP Vulnrichment","metrics":[{"other":{"type":"ssvc","content":{"timestamp":"2025-09-02T13:53:30.343616Z","id":"CVE-2025-58066","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-09-02T13:53:59.838Z"}}]}}}