Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2025-46701

Apache Tomcat: Security constraint bypass for CGI scripts

Description

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.6affected
  • 10.1.0-M1 to ≤ 10.1.40affected
  • 9.0.0.M1 to ≤ 9.0.104affected
  • 8.5.0 to ≤ 8.5.100affected
  • 3 to < 8.5.0unknown
  • 10.0.0-M1 to ≤ 10.0.27unknown

References