{"id":"CVE-2025-46701","state":"PUBLISHED","title":"Apache Tomcat: Security constraint bypass for CGI scripts","description":"Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104.\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions \nmay also be affected.\n\n\nUsers are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.","publishedAt":"2025-05-29T19:06:04.289Z","updatedAt":"2025-11-03T20:04:34.067Z","severity":{"score":7.3,"label":"High","version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","source":"CISA-ADP"},"assigner":"apache","products":["Apache Software Foundation Apache Tomcat"],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Tomcat","defaultStatus":"unaffected","versions":[{"version":"11.0.0-M1","status":"affected","lessThanOrEqual":"11.0.6","versionType":"semver"},{"version":"10.1.0-M1","status":"affected","lessThanOrEqual":"10.1.40","versionType":"semver"},{"version":"9.0.0.M1","status":"affected","lessThanOrEqual":"9.0.104","versionType":"semver"},{"version":"8.5.0","status":"affected","lessThanOrEqual":"8.5.100","versionType":"semver"},{"version":"3","status":"unknown","lessThan":"8.5.0","versionType":"semver"},{"version":"10.0.0-M1","status":"unknown","lessThanOrEqual":"10.0.27","versionType":"semver"}]}],"references":["https://lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j","http://www.openwall.com/lists/oss-security/2025/05/29/4","https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html"],"weaknesses":["CWE-178"],"ingestedAt":"2026-10-29T20:09:17.366Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2025/46xxx/CVE-2025-46701.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.2","cveMetadata":{"cveId":"CVE-2025-46701","state":"PUBLISHED","datePublished":"2025-05-29T19:06:04.289Z","dateUpdated":"2025-11-03T20:04:34.067Z","assignerShortName":"apache","assignerOrgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateReserved":"2025-04-28T12:28:07.568Z"},"containers":{"cna":{"title":"Apache Tomcat: Security constraint bypass for CGI scripts","descriptions":[{"lang":"en","value":"Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104.\nThe following versions were EOL at the time the CVE was created but are \nknown to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions \nmay also be affected.\n\n\nUsers are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue."}],"affected":[{"vendor":"Apache Software Foundation","product":"Apache Tomcat","defaultStatus":"unaffected","versions":[{"version":"11.0.0-M1","status":"affected","lessThanOrEqual":"11.0.6","versionType":"semver"},{"version":"10.1.0-M1","status":"affected","lessThanOrEqual":"10.1.40","versionType":"semver"},{"version":"9.0.0.M1","status":"affected","lessThanOrEqual":"9.0.104","versionType":"semver"},{"version":"8.5.0","status":"affected","lessThanOrEqual":"8.5.100","versionType":"semver"},{"version":"3","status":"unknown","lessThan":"8.5.0","versionType":"semver"},{"version":"10.0.0-M1","status":"unknown","lessThanOrEqual":"10.0.27","versionType":"semver"}]}],"references":[{"url":"https://lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30j","tags":["vendor-advisory"]}],"metrics":[{"other":{"content":{"text":"low"},"type":"Textual description of severity"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-178","description":"CWE-178 Improper Handling of Case Sensitivity","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"apache","orgId":"f0158376-9dc2-43b6-827c-5f631a4d8d09","dateUpdated":"2025-10-29T11:46:02.476Z"},"credits":[{"lang":"en","type":"finder","value":"Greg K (https://github.com/gregk4sec)"}],"source":{"discovery":"EXTERNAL"},"x_generator":{"engine":"Vulnogram 0.2.0"}},"adp":[{"title":"CVE Program Container","references":[{"url":"http://www.openwall.com/lists/oss-security/2025/05/29/4"},{"url":"https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html"}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2025-11-03T20:04:34.067Z"}},{"title":"CISA ADP Vulnrichment","metrics":[{"cvssV3_1":{"scope":"UNCHANGED","version":"3.1","baseScore":7.3,"attackVector":"NETWORK","baseSeverity":"HIGH","vectorString":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","integrityImpact":"LOW","userInteraction":"NONE","attackComplexity":"LOW","availabilityImpact":"LOW","privilegesRequired":"NONE","confidentialityImpact":"LOW"}},{"other":{"type":"ssvc","content":{"timestamp":"2025-05-30T14:58:21.998219Z","id":"CVE-2025-46701","options":[{"Exploitation":"none"},{"Automatable":"yes"},{"Technical Impact":"partial"}],"role":"CISA Coordinator","version":"2.0.3"}}}],"providerMetadata":{"shortName":"CISA-ADP","orgId":"134c704f-9b21-4f2e-91b3-4a467353bcc0","dateUpdated":"2025-05-30T14:58:31.063Z"}}]}}}