Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2025-12044

Vault Vulnerable to Denial of Service Due to Rate Limit Regression

Description

Vault and Vault Enterprise (“Vault”) are vulnerable to an unauthenticated denial of service when processing JSON payloads. This occurs due to a regression from a previous fix for [+HCSEC-2025-24+|https://discuss.hashicorp.com/t/hcsec-2025-24-vault-denial-of-service-though-complex-json-payloads/76393]  which allowed for processing JSON payloads before applying rate limits. This vulnerability, CVE-2025-12044, is fixed in Vault Community Edition 1.21.0 and Vault Enterprise 1.16.27, 1.19.11, 1.20.5, and 1.21.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

HashiCorp Vault

Default version status: unaffected

  • 1.20.3 to < 1.21.0affected

HashiCorp Vault Enterprise

Default version status: unaffected

  • 1.20.3 to < 1.21.0affected
  • 1.19.9 to < 1.19.11affected
  • 1.18.14 to < 1.18.15affected
  • 1.16.25 to < 1.16.27affected

References