Skip to content
CVE PROGRAM SOURCE RECORD6.4 Medium

CVE-2021-39222

XSS in Talk

Description

Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nextcloud security-advisories

  • < 10.0.7affected
  • >= 10.1.0, < 10.1.4affected
  • >= 11.1.0, < 11.1.2affected
  • < 11.2.0affected
  • >= 12.0.0.alpha-1, < 12.0.0affected

References