{"id":"CVE-2021-39222","state":"PUBLISHED","title":"XSS in Talk","description":"Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.","publishedAt":"2021-11-15T18:30:13.000Z","updatedAt":"2024-08-04T01:58:18.181Z","severity":{"score":6.4,"label":"Medium","version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","source":"GitHub_M"},"assigner":"GitHub_M","products":["nextcloud security-advisories"],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 10.0.7","status":"affected"},{"version":">= 10.1.0, < 10.1.4","status":"affected"},{"version":">= 11.1.0, < 11.1.2","status":"affected"},{"version":"< 11.2.0","status":"affected"},{"version":">= 12.0.0.alpha-1, < 12.0.0","status":"affected"}]}],"references":["https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g","https://github.com/nextcloud/spreed/pull/542","https://hackerone.com/reports/1135481"],"weaknesses":["CWE-434","CWE-79"],"ingestedAt":"2026-10-29T19:48:52.666Z","source":{"repository":"CVEProject/cvelistV5","path":"cves/2021/39xxx/CVE-2021-39222.json","commit":"556c9d3a8cd17e218bb8e452ba7cd619a384ff47"},"raw":{"dataType":"CVE_RECORD","dataVersion":"5.1","cveMetadata":{"cveId":"CVE-2021-39222","state":"PUBLISHED","datePublished":"2021-11-15T18:30:13.000Z","dateUpdated":"2024-08-04T01:58:18.181Z","assignerShortName":"GitHub_M","assignerOrgId":"a0819718-46f1-4df5-94e2-005712e83aaa","dateReserved":"2021-08-16T00:00:00.000Z"},"containers":{"cna":{"title":"XSS in Talk","descriptions":[{"lang":"en","value":"Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy."}],"affected":[{"vendor":"nextcloud","product":"security-advisories","versions":[{"version":"< 10.0.7","status":"affected"},{"version":">= 10.1.0, < 10.1.4","status":"affected"},{"version":">= 11.1.0, < 11.1.2","status":"affected"},{"version":"< 11.2.0","status":"affected"},{"version":">= 12.0.0.alpha-1, < 12.0.0","status":"affected"}]}],"references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g","tags":["x_refsource_CONFIRM"]},{"url":"https://github.com/nextcloud/spreed/pull/542","tags":["x_refsource_MISC"]},{"url":"https://hackerone.com/reports/1135481","tags":["x_refsource_MISC"]}],"metrics":[{"cvssV3_1":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"}}],"problemTypes":[{"descriptions":[{"cweId":"CWE-434","description":"CWE-434: Unrestricted Upload of File with Dangerous Type","lang":"en","type":"CWE"}]},{"descriptions":[{"cweId":"CWE-79","description":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')","lang":"en","type":"CWE"}]}],"providerMetadata":{"shortName":"GitHub_M","dateUpdated":"2021-11-15T18:30:13.000Z","orgId":"a0819718-46f1-4df5-94e2-005712e83aaa"},"source":{"advisory":"GHSA-xhxq-f4vg-jw5g","discovery":"UNKNOWN"},"x_legacyV4Record":{"CVE_data_meta":{"ASSIGNER":"security-advisories@github.com","ID":"CVE-2021-39222","STATE":"PUBLIC","TITLE":"XSS in Talk"},"affects":{"vendor":{"vendor_data":[{"product":{"product_data":[{"product_name":"security-advisories","version":{"version_data":[{"version_value":"< 10.0.7"},{"version_value":">= 10.1.0, < 10.1.4"},{"version_value":">= 11.1.0, < 11.1.2"},{"version_value":"< 11.2.0"},{"version_value":">= 12.0.0.alpha-1, < 12.0.0"}]}}]},"vendor_name":"nextcloud"}]}},"data_format":"MITRE","data_type":"CVE","data_version":"4.0","description":{"description_data":[{"lang":"eng","value":"Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy."}]},"impact":{"cvss":{"attackComplexity":"HIGH","attackVector":"NETWORK","availabilityImpact":"NONE","baseScore":6.4,"baseSeverity":"MEDIUM","confidentialityImpact":"HIGH","integrityImpact":"HIGH","privilegesRequired":"LOW","scope":"UNCHANGED","userInteraction":"REQUIRED","vectorString":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"}},"problemtype":{"problemtype_data":[{"description":[{"lang":"eng","value":"CWE-434: Unrestricted Upload of File with Dangerous Type"}]},{"description":[{"lang":"eng","value":"CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')"}]}]},"references":{"reference_data":[{"name":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g","refsource":"CONFIRM","url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g"},{"name":"https://github.com/nextcloud/spreed/pull/542","refsource":"MISC","url":"https://github.com/nextcloud/spreed/pull/542"},{"name":"https://hackerone.com/reports/1135481","refsource":"MISC","url":"https://hackerone.com/reports/1135481"}]},"source":{"advisory":"GHSA-xhxq-f4vg-jw5g","discovery":"UNKNOWN"}}},"adp":[{"title":"CVE Program Container","references":[{"url":"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xhxq-f4vg-jw5g","tags":["x_refsource_CONFIRM","x_transferred"]},{"url":"https://github.com/nextcloud/spreed/pull/542","tags":["x_refsource_MISC","x_transferred"]},{"url":"https://hackerone.com/reports/1135481","tags":["x_refsource_MISC","x_transferred"]}],"providerMetadata":{"shortName":"CVE","orgId":"af854a3a-2127-422b-91ae-364da2661108","dateUpdated":"2024-08-04T01:58:18.181Z"}}]}}}