Description
A vulnerability was identified in Pixelfed up to 0.12.11. Impacted is the function instancePeers of the file app/Http/Controllers/Api/ApiV1Controller.php of the component OAuth Scope Handler. Such manipulation of the argument ID leads to missing authentication. The attack may be performed from remote. The exploit is publicly available and might be used. Upgrading to version 0.12.10 is recommended to address this issue. The name of the patch is 68dca5097305fa0065d029587b2233524636025a. Upgrading the affected component is advised.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n/a Pixelfed
0.12.0affected0.12.1affected0.12.2affected0.12.3affected0.12.4affected0.12.5affected0.12.6affected0.12.7affected0.12.8affected0.12.9affected0.12.10affected0.12.11affected0.12.10unaffected
References
- https://vuldb.com/vuln/407919 ↗
- https://vuldb.com/vuln/407919/cti ↗
- https://vuldb.com/cve/CVE-2026-93960 ↗
- https://vuldb.com/submit/944207 ↗
- https://github.com/pixelfed/pixelfed/issues/6643 ↗
- https://github.com/pixelfed/pixelfed/pull/6774 ↗
- https://github.com/pixelfed/pixelfed/commit/68dca5097305fa0065d029587b2233524636025a ↗
- https://github.com/pixelfed/pixelfed/releases/tag/v0.12.10 ↗
- https://github.com/pixelfed/pixelfed/ ↗