Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-93534

spatie Scotty Self Update SelfUpdater.php update code download

Description

A vulnerability was identified in spatie Scotty up to 1.4.2. Affected is the function SelfUpdater::update of the file app/Updater/SelfUpdater.php of the component Self Update Handler. Such manipulation leads to download of code without integrity check. It is possible to launch the attack remotely. Upgrading to version 1.4.3 is able to address this issue. The name of the patch is 4b4e11bfc98e3a2159bb2b3d9b040293fcc44744. It is advisable to upgrade the affected component.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

spatie Scotty

  • 1.4.0affected
  • 1.4.1affected
  • 1.4.2affected
  • 1.4.3unaffected

References