Skip to content
CVE PROGRAM SOURCE RECORD8.5 High

CVE-2026-93337

NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection

Description

NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

nm-l2tp NetworkManager-l2tp

Default version status: unaffected

  • 0 to ≤ 1.52.4affected
  • 1.52.6unaffected
pkg:github/nm-l2tp/NetworkManager-l2tp

References