Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-89238

Apache WSS4J: WSS4J EncryptedHeader child confusion causing wrong protected-header selection

Description

WSS4J EncryptedHeader child confusion could promote an attacker-controlled plaintext element as the decrypted header, leading to incorrect confidentiality coverage and possible policy bypass. Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache WSS4J

Default version status: unaffected

  • 4.0.0 to < 4.0.2affected
  • 3.0.0 to < 3.0.6affected
  • 0 to < 2.4.4affected
pkg:maven/org.apache.wss4j/wss4j-ws-security-dom

References