Description
A weakness has been identified in opengeos GeoLibre up to 2.3.0. Impacted is the function _is_within_roots. This manipulation causes server-side request forgery. The attack can be initiated remotely. Upgrading to version 2.4.0 is recommended to address this issue. Patch name: b745f62e29fa37364686525a21eee5e5c0f8a369. It is recommended to upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
opengeos GeoLibre
2.0affected2.1affected2.2affected2.3.0affected2.4.0unaffected
References
- https://vuldb.com/vuln/399812 ↗
- https://vuldb.com/vuln/399812/cti ↗
- https://vuldb.com/cve/CVE-2026-86806 ↗
- https://vuldb.com/submit/911055 ↗
- https://github.com/opengeos/GeoLibre/issues/1573 ↗
- https://github.com/opengeos/GeoLibre/pull/1571 ↗
- https://github.com/opengeos/GeoLibre/commit/b745f62e29fa37364686525a21eee5e5c0f8a369 ↗
- https://github.com/opengeos/GeoLibre/releases/tag/v2.4.0 ↗
- https://github.com/opengeos/GeoLibre/ ↗