Skip to content
CVE PROGRAM SOURCE RECORD7.4 High

CVE-2026-86247

Apache Tomcat Native: Client certificate requirements can be down-graded

Description

Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat Native

Default version status: unaffected

  • 2.0.0 to ≤ 2.0.15affected
  • 1.3.0 to ≤ 1.3.8affected

References