Description
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
SpecterOps BloodHound
9.0.0affected9.1.0affected9.2.2affected9.4.0affected9.5.0affected9.5.1affected9.6.0-rc1unaffected9.6.0unaffected9.7.0-rc3unaffected
References
- https://vuldb.com/vuln/398471 ↗
- https://vuldb.com/vuln/398471/cti ↗
- https://vuldb.com/cve/CVE-2026-85241 ↗
- https://vuldb.com/submit/894488 ↗
- https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebb ↗
- https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1 ↗
- https://github.com/SpecterOps/BloodHound/ ↗