Skip to content
CVE PROGRAM SOURCE RECORD5.9 Medium

CVE-2026-84890

undici vulnerable to Denial of Service via unbounded decompression of compressed responses

Description

undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

undici undici

Default version status: unaffected

  • 7.15.0 to < 7.29.1affected
  • 7.29.1unaffected
  • 8.0.0 to < 8.10.2affected
  • 8.10.2unaffected
pkg:npm/undici

References