Skip to content
CVE PROGRAM SOURCE RECORD4.8 Medium

CVE-2026-84188

librenms before 26.7.0 Stored XSS via graph_descr settings

Description

LibreNMS versions <= 26.4.0 contain a stored cross-site scripting vulnerability in the graph_descr.<graphtype> configuration settings, which are echoed verbatim without HTML escaping in includes/html/pages/graphs.inc.php. An administrator can store a malicious HTML payload that executes in the browser of any authenticated user who views the affected graph type. The issue is fixed in version 26.7.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

librenms librenms

Default version status: unaffected

  • 0 to < 26.7.0affected
  • 26.7.0unaffected
pkg:composer/librenms/librenms

References