Skip to content
CVE PROGRAM SOURCE RECORD5.3 Medium

CVE-2026-82806

Apache APISIX: cross-request permission pollution via static permission list mutation

Description

Exposure of data element to wrong session vulnerability in Apache APISIX. This issue affects Apache APISIX: from 2.3.0 before 3.7.0. Under a supported authz-keycloak configuration, a request's authorization scope could persist into later requests on the same route, leading to unintended authorization expansion and inconsistent access-control decisions. Users are recommended to upgrade to version 3.7.0 or higher, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache APISIX

Default version status: unaffected

  • 2.3.0 to < 3.7.0affected

References