Description
A vulnerability was found in liketrek TREK up to 3.0.22. Impacted is the function loginUser of the file server/src/services/authService.ts of the component Pre-2FA mfa_token Handler. The manipulation results in improper authentication. The attack may be performed from remote. Upgrading to version 3.1.0 is recommended to address this issue. Upgrading the affected component is recommended.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
liketrek TREK
3.0.0affected3.0.1affected3.0.2affected3.0.3affected3.0.4affected3.0.5affected3.0.6affected3.0.7affected3.0.8affected3.0.9affected3.0.10affected3.0.11affected3.0.12affected3.0.13affected3.0.14affected3.0.15affected3.0.16affected3.0.17affected3.0.18affected3.0.19affected3.0.20affected3.0.21affected3.0.22affected3.1.0unaffected