Description
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability in the git_show tool. The model-supplied rev parameter is passed unvalidated into the git show argv without an --end-of-options sentinel, so a value beginning with --output= is interpreted as a git flag. Because the tool is registered as auto-approved and advertised as read-only, an attacker (via a malicious repository combined with prompt injection) can cause an unprompted arbitrary file write at the privilege of the invoking user, targeting sensitive files such as ~/.ssh/authorized_keys, ~/.bashrc, or ~/.gitconfig. Fixed in codewhale / codewhale-tui 0.8.64 by adding rev validation; the deprecated deepseek-tui crate has no fixed release.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Hmbown CodeWhale
Default version status: unaffected
0.3.27 to ≤ 0.8.41affected
pkg:cargo/deepseek-tuiHmbown CodeWhale
Default version status: unaffected
0.3.27 to < 0.8.41affected0.8.41unaffected
pkg:npm/deepseek-tuiHmbown CodeWhale
Default version status: unaffected
0.8.41 to < 0.8.64affected0.8.64unaffected
pkg:cargo/codewhale-tuiHmbown CodeWhale
Default version status: unaffected
0.8.41 to < 0.8.64affected0.8.64unaffected
pkg:npm/codewhale