Skip to content
← Vulnerability catalog
OFFICIAL CVE RECORD7.3 High

CVE-2026-75857

CodeWhale before 0.8.64 Privilege Escalation via exec_shell_interact

Description

CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_interact (alias exec_interact) tool, whose approval_requirement returns ApprovalRequirement::Auto. This overrides the default Required approval for code-executing tools, so LLM-controlled stdin is written into an already-approved long-running interactive shell (e.g., a python3 -i REPL, mysql, ssh, or sudo -i session) without any approval prompt. An attacker who can inject instructions via untrusted content the agent ingests (a fetched page, MCP result, or repo file) can cause commands to run at the privilege level of that approved process. Fixed in codewhale / codewhale-tui 0.8.64; the deprecated deepseek-tui crate has no fixed release.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Hmbown CodeWhale

Default version status: unaffected

  • 0.3.10 to ≤ 0.8.41affected
pkg:cargo/deepseek-tui

Hmbown CodeWhale

Default version status: unaffected

  • 0.3.10 to < 0.8.41affected
  • 0.8.41unaffected
pkg:npm/deepseek-tui

Hmbown CodeWhale

Default version status: unaffected

  • 0.8.41 to < 0.8.64affected
  • 0.8.64unaffected
pkg:cargo/codewhale-tui

Hmbown CodeWhale

Default version status: unaffected

  • 0.8.41 to < 0.8.64affected
  • 0.8.64unaffected
pkg:npm/codewhale

References