Skip to content
CVE PROGRAM SOURCE RECORD7.0 High

CVE-2026-75020

Apache APISIX: ldap-auth plugin cross-subtree identity impersonation

Description

Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection') vulnerability in Apache APISIX. A caller who holds valid credentials for one entry in the LDAP directory can authenticate through APISIX as a consumer mapped to a different entry, one the plugin's configured scope was meant to keep out of reach. This issue affects Apache APISIX: from 2.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache APISIX

Default version status: unaffected

  • 2.11.0 to ≤ 3.17.0affected

References