Skip to content
CVE PROGRAM SOURCE RECORD7.7 High

CVE-2026-73626

JupyterLab before 4.6.2 Authentication Bypass via PyPIExtensionManager

Description

JupyterLab versions >=4.6.0,<=4.6.1 and <=4.5.9 contain an allowlist/blocklist enforcement gap in PyPIExtensionManager.install(). A missing 'await' caused the is_install_allowed coroutine to never execute, so the extension allowlist/blocklist check was not enforced for direct callers of install(). The stock JupyterLab HTTP API and Extension Manager UI are not affected, as they perform a separate, correctly awaited check. The issue affects only deployments where a custom extension or downstream integration imports PyPIExtensionManager and calls install() directly with a package name influenced by untrusted input, an allowlist/blocklist is configured, the PyPI Extension Manager is enabled, and kernels and terminals are disabled or delegated to remote hosts. Fixed in JupyterLab 4.6.2 and 4.5.10.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

jupyterlab jupyterlab

Default version status: unaffected

  • 4.6.0 to < 4.6.1affected
  • 4.6.1unaffected
pkg:pypi/jupyterlab

jupyterlab jupyterlab

Default version status: unaffected

  • 0 to < 4.5.10affected
  • 4.5.10unaffected
pkg:pypi/jupyterlab

References