Skip to content
CVE PROGRAM SOURCE RECORD6.1 Medium

CVE-2026-73192

Apache Sling XSS: XSS possible through XSSAPI.getValidHref()

Description

An improper neutralization of input during web page generation ('Cross-site Scripting') [CWE-79] vulnerability when using the XSSAPI.getValidHref() in Apache Sling XSS version 2.4.10 and prior may allow an attacker to perform a reflected cross-site scripting (XSS) attack in every feature using this method. In order to successfully attack an application, the attacker needs to be able to submit a value which is not correctly sanitized by that library. Upgrade to Apache Sling XSS >= 2.4.12

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Sling XSS

Default version status: unaffected

  • 0 to < 2.4.12affected

References