Skip to content
← Vulnerability catalog
OFFICIAL CVE RECORD8.7 High

CVE-2026-72831

Grav through 2.0.11 Authentication Bypass via Flex Objects

Description

The Flex Objects plugin (through 1.4.6, tested with Grav 2.0.11) contains an incorrect authorization vulnerability in its Flex Objects API. FlexApiController::update() checks only the general Flex directory permission and does not apply the additional target/field/super-admin checks enforced by the dedicated Users and Groups API controllers. An authenticated account with api.access, admin.login, and users.update permissions (but without api.users.write or admin.super) can use the generic /api/v1/flex-objects/user-accounts endpoint to change a super administrator's password, or the /api/v1/flex-objects/user-groups endpoint to grant its group admin.super, resulting in full site takeover. Fixed in Flex Objects 1.4.7.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

getgrav grav

Default version status: unaffected

  • 2.0.11 to ≤ 2.0.11affected

trilbymedia grav-plugin-flex-objects

Default version status: unaffected

  • 0 to < 1.4.7affected
  • 1.4.7unaffected

References