Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2026-72524

Apache Doris: Authorization bypass allowing a low-privilege user to read/write/drop arbitrary tables

Description

Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access or modify data they are not authorized to. This issue affects Apache Doris: from 3.1.0 through 3.1.*, from 4.0.0 through 4.0.7, and from 4.1.0 through 4.1.3. Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4), which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Doris

Default version status: unaffected

  • 3.1.0 to ≤ 3.1.*affected
  • 4.0.0 to ≤ 4.0.7affected
  • 4.1.0 to ≤ 4.1.3affected

References