Description
The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.18, 2.1.4, 3.0.6, and 5.0.9, expand() does not apply maxLength while constructing comma-alternative intermediate arrays or padded sequences, allowing attacker-controlled input to exhaust memory or block the event loop. The fix for CVE-2026-14257 is bypassed by the vulnerability. This issue is fixed in versions 1.1.18, 2.1.4, 3.0.6, and 5.0.9.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
juliangruber brace-expansion
< 1.1.18affected>= 2.0.0, < 2.1.4affected>= 3.0.0, < 3.0.6affected>= 4.0.0, < 5.0.9affected
References
- https://github.com/juliangruber/brace-expansion/security/advisories/GHSA-rgw5-rvv9-x895 ↗
- https://github.com/juliangruber/brace-expansion/commit/139d015104e71433ad52a41d19467c48ecbb2c7d ↗
- https://github.com/juliangruber/brace-expansion/commit/1e30c930238d7162802d88a94189182def178dac ↗
- https://github.com/juliangruber/brace-expansion/commit/688a99eeaab02627c2b89ba8ba4821fecfa659cf ↗
- https://github.com/juliangruber/brace-expansion/commit/cb4b9e47cc2ec777c14b2b4492fb431a56f6a031 ↗