Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-69077

Apache Kylin: JobController allows unauthorized cross-project manipulation

Description

Exposure of unauthorized cross-project job manipulation vulnerability in Apache Kylin. Impact most to the kylin services that are directly exposed to public network, which is not common. In-house kylin deployments are mostly not impacted. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Kylin

Default version status: unaffected

  • 4..0.0 to ≤ 5.0.4affected

References