Skip to content
CVE PROGRAM SOURCE RECORD8.1 High

CVE-2026-68569

Apache Tomcat: Principal lookup can fail open in some cases

Description

Improper Authentication vulnerability in Apache Tomcat meant that in some circumstances (e.g. CLIENT-CERT, SPNEGO) that a user would be authenticated even if the user did not exist in the DataSourceRealm. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.24affected
  • 10.1.0-M1 to ≤ 10.1.57affected
  • 9.0.0.M1 to ≤ 9.0.120affected
  • 8.5.0 to ≤ 8.5.100affected
  • 7.0.0 to ≤ 7.0.109affected
  • 0 to < 7.0.0unknown

References