Description
Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache Tomcat
Default version status: unaffected
11.0.0-M1 to ≤ 11.0.24affected10.1.0-M1 to ≤ 10.1.57affected9.0.25 to ≤ 9.0.120affected8.5.46 to ≤ 8.5.100affected7.0.97 to ≤ 7.0.109affected0 to < 7.0.97unaffected