Skip to content
← Vulnerability catalog
OFFICIAL CVE RECORD8.9 High

CVE-2026-65591

n8n before 1.123.64 Sanitizer Bypass Remote Code Execution

Description

n8n contains a sanitizer bypass vulnerability in the legacy expression evaluator's computed-member handler. An authenticated user with workflow create or modify permissions can craft a malicious expression to bypass the sanitizer and achieve host-level code execution as the n8n process. The legacy expression engine is the default in affected versions. Fixed in n8n 1.123.64, 2.29.8, and 2.30.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

n8n-io n8n

Default version status: unaffected

  • 0 to < 1.123.64affected
  • 1.123.64unaffected
pkg:npm/n8n

n8n-io n8n

Default version status: unaffected

  • 2.30.0 to < 2.30.1affected
  • 2.30.1unaffected
pkg:npm/n8n

n8n-io n8n

Default version status: unaffected

  • 2.0.0-rc.0 to < 2.29.8affected
  • 2.29.8unaffected
pkg:npm/n8n

References