Skip to content
CVE PROGRAM SOURCE RECORD6.9 Medium

CVE-2026-64627

Parse Server 9.0.0 Schema Disclosure via GraphQL Variable Coercion

Description

Parse Server versions >= 9.0.0 before 9.10.0-alpha.4 and versions before 8.6.85 contain a schema disclosure vulnerability. When the GraphQL API is mounted with public introspection disabled (graphQLPublicIntrospection: false, the default), schema-derived 'Did you mean ...?' suggestions were still returned in GraphQL error messages produced during variable coercion, which were not covered by the introspection-hardening control (that only handled validation errors). An unauthenticated caller possessing only the public application id can iteratively recover hidden schema identifiers — including registered Cloud Code function names and Parse class and field names — by submitting queries or mutations whose variables contain near-miss enum values or input-object field names. This is a follow-up bypass of GHSA-8cph-rgr4-g5vj. The issue is fixed in 9.10.0-alpha.4 and 8.6.85.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

parse-community parse-server

Default version status: unaffected

  • 9.0.0 to < 9.10.0-alpha.4affected
  • 9.10.0-alpha.4unaffected
pkg:npm/parse-server

parse-community parse-server

Default version status: unaffected

  • 0 to < 8.6.85affected
  • 8.6.85unaffected
pkg:npm/parse-server

References