Description
Deserialization of untrusted data vulnerability that may allow class-registration checks to be bypassed during Java lambda deserialization. Only lambda capture class is affected This issue affects Apache Fory: from before 1.4.0. Users are recommended to upgrade to version 1.4.0, which fixes the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache Fory
Default version status: unaffected
0.11.0 to < 1.4.0affected
Apache Software Foundation Apache Fory
Default version status: unaffected
0.5.0 to < 0.11.0affected