Skip to content
CVE PROGRAM SOURCE RECORD9.8 Critical

CVE-2026-62390

Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API

Description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Kylin

Default version status: unaffected

  • 4 to ≤ 5.0.3affected

References