Description
Improper Input Validation vulnerability in Apache ActiveMQ AMQP, Apache ActiveMQ, Apache ActiveMQ All. A remote unauthenticated peer that can reach an exposed AMQP NIO connector can trigger denial-of-service behavior by sending a frame size value. This cause the NIO threads to die and if done rapidly enough can lead to exhaustion of the NIO thread pool denying service to other connections. This issue affects Apache ActiveMQ AMQP: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ: before 5.19.9, from 6.0.0 before 6.2.8; Apache ActiveMQ All: before 5.19.9, from 6.0.0 before 6.2.8. Users are recommended to upgrade to version 5.19.9, 6.2.8, or 6.3.0 which fixes the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache ActiveMQ AMQP
Default version status: unaffected
0 to < 5.19.9affected6.0.0 to < 6.2.8affected
Apache Software Foundation Apache ActiveMQ
Default version status: unaffected
0 to < 5.19.9affected6.0.0 to < 6.2.8affected
Apache Software Foundation Apache ActiveMQ All
Default version status: unaffected
0 to < 5.19.9affected6.0.0 to < 6.2.8affected