Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-59655

Apache CloudStack: Unauthenticated OAuth provider client-secret disclosure

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache CloudStack's OAuth authentication plugin while listing OAuth providers. This issue affects Apache CloudStack: from 4.19.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache CloudStack

Default version status: unaffected

  • 4.19.0.0 to ≤ 4.20.3.0affected
  • 4.21.0.0 to ≤ 4.22.1.0affected

References