Skip to content
CVE PROGRAM SOURCE RECORD8.2 High

CVE-2026-58185

Apache Traffic Server: Use-after-free in the intercept plugin

Description

The Apache Traffic Server intercept plugin has a use-after-free. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Traffic Server

Default version status: unaffected

  • 8.0.0 to ≤ 8.1.11affected
  • 9.0.0 to ≤ 9.2.14affected
  • 10.0.0 to ≤ 10.1.3affected

References