Description
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
n8n n8n
Default version status: unaffected
0 to < 1.123.27affected1.123.27unaffected2.0.0-rc.0 to < 2.13.3affected2.13.3unaffected2.14.0 to < 2.14.1affected2.14.1unaffected
pkg:npm/n8nn8n n8n
Default version status: unaffected
2.14.0 to < 2.14.1affected2.14.1unaffected
pkg:npm/n8nn8n n8n
Default version status: unaffected
2.0.0-rc.0 to < 2.13.3affected2.13.3unaffected
pkg:npm/n8n