Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2026-55956

Apache Tomcat: Security constraints for default servlet ignored method

Description

Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Tomcat

Default version status: unaffected

  • 11.0.0-M1 to ≤ 11.0.22affected
  • 10.1.0-M1 to ≤ 10.1.55affected
  • 9.0.0.M1 to ≤ 9.0.118affected
  • 8.5.0 to ≤ 8.5.100affected
  • 7.0.0 to ≤ 7.0.109affected
  • 0 to < 7.0.0unknown

References