Skip to content
CVE PROGRAM SOURCE RECORD7.5 High

CVE-2026-5079

multer vulnerable to Denial of Service via deeply nested field names

Description

Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

multer multer

Default version status: unaffected

  • 1.0.0 to < 2.2.0affected
  • 2.2.0unaffected
  • 3.0.0-alpha.1 to < 3.0.0-alpha.2affected
  • 3.0.0-alpha.2unaffected
pkg:npm/multer

References