Description
A JNDI Injection vulnerability has been discovered in Apache CXF's JCA integration module, which can allow for code execution, if an attacker is able to manipulate the JCA deployment descriptor (ra.xml) or runtime activation parameters. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache CXF
Default version status: unaffected
4.2.0 to < 4.2.2affected4.0.0 to < 4.1.7affected0 to < 3.6.12affected
References
- https://lists.apache.org/thread/1czhgovkgzdkyp3t61wthn0foogh2grf ↗
- http://www.openwall.com/lists/oss-security/2026/06/11/10 ↗
- https://access.redhat.com/security/cve/CVE-2026-50633 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2488307 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50633.json ↗
- https://access.redhat.com/errata/RHSA-2026:37390 ↗