Description
A further incomplete fix for a previous advisory CVE-2026-44417 (Untrusted JMS configuration can lead to RCE) for Apache CXF has been identified, which can allow code execution capabilities, if untrusted users are allowed to configure JMS for Apache CXF. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache CXF
Default version status: unaffected
4.2.0 to < 4.2.2affected4.0.0 to < 4.1.7affected0 to < 3.6.12affected
References
- https://lists.apache.org/thread/740ghch5z5y675cn2kzgtyo5k37n6qcw ↗
- https://access.redhat.com/security/cve/CVE-2026-50632 ↗
- https://bugzilla.redhat.com/show_bug.cgi?id=2488304 ↗
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-50632.json ↗
- https://access.redhat.com/errata/RHSA-2026:37390 ↗