Description
Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache ActiveMQ Broker
Default version status: unaffected
0 to < 5.19.8affected6.0.0 to < 6.2.7affected
Apache Software Foundation Apache ActiveMQ
Default version status: unaffected
0 to < 5.19.8affected6.0.0 to < 6.2.7affected
Apache Software Foundation Apache ActiveMQ All
Default version status: unaffected
0 to < 5.19.8affected6.0.0 to < 6.2.7affected