Description
Exposure of Sensitive Information Through Metadata vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. Brokers that are configured with a network connector with syncDurableSubs set to true, are vulnerable to an unauthenticated attacker who can receive a list of all durable topic subscriptions in the broker, including client identifiers, subscription names, topic destinations, and JMS selector expressions, by sending a BrokerInfo command. The broker incorrectly responds without first ensuring the connection is authenticated. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.
Affected products
Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.
Apache Software Foundation Apache ActiveMQ Broker
Default version status: unaffected
5.14.0 to < 5.19.7affected6.0.0 to < 6.2.6affected
Apache Software Foundation Apache ActiveMQ
Default version status: unaffected
5.14.0 to < 5.19.7affected6.0.0 to < 6.2.6affected
Apache Software Foundation Apache ActiveMQ All
Default version status: unaffected
5.14.0 to < 5.19.7affected6.0.0 to < 6.2.6affected