Skip to content
CVE PROGRAM SOURCE RECORD8.8 High

CVE-2026-49157

Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by default

Description

Incorrect Default Permissions vulnerability in Apache ActiveMQ. This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue. Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache ActiveMQ

Default version status: unaffected

  • 0 to < 5.19.7affected
  • 6.0.0 to < 6.2.6affected

References