Skip to content
CVE PROGRAM SOURCE RECORD7.3 High

CVE-2026-49042

Apache Camel: langchain4j-tools: filter tool argument headers against declared parameters

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: from 4.8.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.18.3, 4.21.0, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache Camel

Default version status: unaffected

  • 4.8.0 to ≤ 4.18.2affected
  • 4.19.0 to ≤ 4.20.0affected

References