Skip to content
CVE PROGRAM SOURCE RECORD6.5 Medium

CVE-2026-48910

Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing

Description

A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This issue affects Apache JSPWiki: through 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes the issue.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

Apache Software Foundation Apache JSPWiki

Default version status: unaffected

  • 0 to ≤ 2.12.3affected

References