Skip to content
CVE PROGRAM SOURCE RECORD9.1 Critical

CVE-2026-48746

vLLM: OpenAI auth bypass

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

vllm-project vllm

  • >= 0.3.0, < 0.22.0affected

References