Skip to content
CVE PROGRAM SOURCE RECORD8.7 High

CVE-2026-47762

TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments

Description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Affected products

Version statuses are supplied by the assigning organization. Consult the original record for detailed ranges and platform conditions.

tinymce tinymce

  • < 5.11.1affected
  • >= 6.0.0, <= 6.8.6affected
  • >= 7.0.0, < 7.9.3affected
  • >= 8.0.0, < 8.5.1affected

References